Advanced FAQ

Advanced FAQ

How do I make awnings look more realistic?
What makes an awning look realistic is varying levels of shading across its various parts. You can adjust the shading by changing the direction of the light to get the most realistic looking shading.  You can do this with the Rotate Light button or the Time slider in the Sky tab.  You can also use the Ambient Light slider in the Light tab to adjust the amount of background light in the scene.  The Specular Light slider in the Light tab works on objects that are shiny like frame components or poles.  This slider adjusts the intensity of the light that reflects off the object directly towards the viewer.

How do I make dark colored awnings look more realistic?
Dark colored materials such as navy blue and black fabric can be difficult to work with because they reflect only a small amount of light.  This makes it harder to see variations in brightness across the surface of the object. The darker colors in version 5 have been adjusted to compensate for this problem and should work better than in version 4.  We are also working on some other lighting controls that may help with this problem in the future.

How do I apply a valance?
Select the awning by clicking on it.  (You should see the X, Y, and Z axis lines running through the center of it.)  Then click on the Apply Valance button.  Click on a valance to apply it.  You can click on several styles to quickly try different ones.  When you've decided on the style to use, double-click on the valance to apply it and close the list.

Note that for striped fabrics, the number of valance cutouts will be determined by the fabric repeat.  Stripes can be aligned with the cutouts using the Horizontal Offset slider in the Texture tab in the lower left.

How do I adjust the look of a valance?
Awning Composer includes over 25 pre-defined valance styles.  Each of these valance styles can be adjusted in various ways.  After the valance has been applied, look at the Object Parts list in the upper left.  Find the part called “Valance” and click on it.  Then go to the Valance tab in the lower left.  A list of valance measurements will be displayed.  Any of these measurements can be changed by typing a new value into the “Specified” column.  (The “Actual” column is for reference only and displays the actual value in use, which may differ from the specified value – for example when no value is specified.)

How do I apply a graphic to the front face and valance of an awning?
We'd like to make this easier in the future, but it is possible now by following these steps:
1) Apply the same graphic to the front panel and then to the valance.
2) Make the two graphics the same width by typing in the width in the dimensions textbox for each graphic.
3) Line up the two graphics so that they meet at the seam between the front face and the valance.   You will have to bring the graphic on the awning face down and the graphic on the valance up until they meet at the exact right place.  It may be easier to zoom in and use the X and Y axis locks to move along only one axis at a time.

How do I change the font of text applied to my awning?
After applying text to the awning, look at the Object Parts box in the upper left.  Find the part called “Text” and click on it.  Alternatively, you can click on the text itself in the 3D view.  When the text is selected, there will be a dashed line around it in the 3D view.  Go to the Text tab in the lower left and use the various controls for selecting the font face, font style, text color, etc.

How do I insert symbols like bullets/copyright/etc. into text?
First, run the Character Map application that comes with Windows.  On Windows XP/Vista/7, click Start, Accessories, System Tools and then Character Map.  On Windows 8, use the search function (accessible from the start screen), type in “Char”, and choose the Character Map application.

In Character Map, start by choosing the font you're using for the text in Awning Composer.  Then, at the bottom of the window, check the "Advanced view" checkbox to make the search box visible.  In the search box, type the name of the special character such as “bullet” or “copyright”.  Character Map will show a list of special characters that match the name you entered.  You can also scroll through the character map and visually identify the special character you're looking for.  Double click on the desired character and it will appear in the “Characters to copy” box.  You can repeat this step if multiple characters are needed.  Then click on the “Copy” button to the right of this box to copy the character(s) to the clipboard.

Return to Awning Composer and click in the textbox where you want to insert the character(s).  Then press Ctrl+V or right-click in the textbox and choose Paste.

How can I see the side of an awning when I have a straight-on backdrop?
When using a straight-on backdrop (or no backdrop), you can use the camera controls to view the scene from any angle. While in the default Select Object mode, hold down the middle mouse button and drag the mouse to change the camera angle.  You can also roll the mouse wheel up or down to zoom in or out.  There are also several camera modes located in the ribbon in the Camera section.  Refer to the help file for more information about these camera modes.

How do I make an inside or outside corner between two awnings?
The Add Corner feature is not yet available in version 5.  We suggest that you use version 4 for corners until this feature is implemented in version 5.

How do I show my customer an awning that is constructed from two panels of solid fabric?
Create an image file that contains the desired pattern, and then import it using the Image button in the Texture tab in the lower left.  To create the image file, you can use the Pattern Editor in version 4 or any paint program such as Paint.NET.

How do I remove the sides of an awning so just the top remains?
Select the awning by clicking on it.  (You should see the X, Y, and Z axis lines running through the center of it.)  Look at the Object Parts list in the upper left.  You should see eye icons next to each part of the awning that indicate whether a part is visible or hidden.  If the eye is open, then the part is displayed.  If the eye is closed, then the part is not displayed.  Clicking on the eye will cycle its setting between open and closed.  So, to remove the sides, click on the eye icons next to the right and left part names.

How do I show the awning frame?
Awning Composer includes some awning models that have internal frame components.  Click the Add Object button and go to the Frames tab.  These frames can be adjusted for height, width and depth, but the proportions of the frame may become distorted and the rafter spacing cannot be adjusted.  You can also turn on the fabric to cover over these frames.  We recommend using these models for demonstrating general styles only, rather than the specific awning being constructed.  In the future, we’re planning to offer a dynamic frame capability that will build a realistic frame using a comprehensive set of measurements.

How do I create my own awning frame?
You can create a solid 3D model in 3D modeling software such as SketchUp Pro, SolidWorks, or Blender and import it into Awning Composer.  These applications are general purpose CAD tools and the learning curve is steep.  If you haven’t done 3D modeling before, it may take some time to learn.  Please contact us for more information.

How do I create channel letters?
Version 5 does not yet have the capability to produce channel letters (3D text).  We suggest that you use the 3D text feature built into version 4 until this feature is available in version 5.  Alternatively, you can create a 3D model of the text in another program such as Blender, export it as an OBJ file, and import it into version 5.

How do I apply a graphic using a logo from a PDF file?
You will need to extract the logo from the PDF file and convert it to a transparent PNG image file.  You can do this using vector graphics editing software.  For software recommendations and download links, visit the Recommended Software page.

The following detailed instructions are for use with Inkscape, a free vector graphics editor:

Opening the PDF file in Inkscape

Start Inkscape using its desktop or start menu shortcut.  Go to the File menu and choose Open.  At the bottom of the "Select file to open" window, next to "Files of type:", choose Adobe PDF.  Select the PDF file that contains the logo and click Open.  The "PDF Import Settings" window will appear.  If the PDF file has multiple pages, choose the page of the PDF file the logo is on.  Click OK to open the file.

Once the file has been opened, maximize the Inkscape window and hit the + key on the keyboard to zoom in a bit.  Make sure the entire logo is visible on the screen.  You can press the - key to zoom out if needed.

Selecting the logo

Next you'll need to select the logo that you want to export.  Depending on how the PDF file was created, the logo could be an image, a vector graphic, or a number of separate objects that all need to be selected and exported together.  The following instructions will walk you through selecting the necessary object(s), attempting to account for the various possibilities you may encounter with different PDF files.

Start by clicking on the logo.  You should see a dashed selection box appear with arrows at its corners and edges.  Ideally this box will contain exactly the area of the logo - no more, no less.  If the selection box contains only around a part of the logo, like a letter or shape within the logo, that means you'll need to select multiple objects to select the entire logo.  To do this, draw a box around all of the objects by dragging with the mouse button held down from the upper left to the lower right of the box.

If the selection box contains more than just the logo (possibly as much as the entire page), hold down the Ctrl key and click on the logo.  If that doesn't help, the logo may be part of a larger image, in which case you'll need to export the entire image and then crop it in a paint program afterwards.

Once you've made your selection, test it by dragging the logo to the side a little bit.  If you have the correct object(s) selected, the entire logo will move.  Before proceeding, undo the test move by pressing Ctrl+Z or choosing Undo from the Edit menu.  Then, if only part of the logo was moved during your test, you'll need to draw a box around the logo as described above and try this test again.

Exporting the logo

Once you have the correct object(s) selected, go to the File menu and choose Export Bitmap.

In the Export Bitmap window, the Selection button should be selected at the top. (The others will work, but Selection is generally the easiest.) Now check the width and height under Bitmap Size. The higher number should be in the range from 500 to 2000 pixels. If it's not, type in a new value (like 1024). Inkscape will automatically calculate the other dimension. Ignore the DPI value, as it's not relevant in this situation.

Under Filename, click Browse and specify a location and filename to export the image as. Choose PNG as the file type. Then click Export to export the selection as a transparent PNG file.

Applying the logo as a graphic in Awning Composer

At this point, you can try applying the exported file as a graphic in Awning Composer.  If the logo was originally created using vector graphics, it should now appear correctly (without a solid color background) in Awning Composer.  If the logo's background is lacking necessary transparency, you'll need to open the exported file in an image editor such as Paint.NET and edit the image to make the background transparent.  Refer to the Awning Composer documentation for detailed instructions on how to do this.  Finally, if the image contains more than just the logo, you'll need to open the exported file in an image editor such as Paint.NET and crop it to only include the logo, then save it and apply it as a graphic in Awning Composer.

Awning Composer® and Trivantage® are registered trademarks of Glen Raven, Inc. Copyright © 2017.
Privacy Policy | Terms of Use | Trademarks